Flavourful Main Website Down
Incident Report for Flavourful
Resolved
This incident has now been resolved. We appreciate your understanding
Posted Oct 06, 2021 - 07:07 UTC
Investigating
Our website development team have received an update regarding an issue with on of our services. Please bear with us as we identify the source of the issue. We are sorry for anyone who is affected. Our team will provide an update as soon as more information is available.
Posted Oct 06, 2021 - 07:06 UTC
This incident affected: Flavourful Main Website & Bog.