Flavourful All Services Outage
Incident Report for Flavourful
Resolved
This incident has been resolved.
Posted Jun 20, 2022 - 11:14 UTC
Investigating
We are currently investigating this issue.
Posted Jun 20, 2022 - 10:30 UTC
This incident affected: Flavourful Main Website & Bog, Flavourful Merch Shelf and Support Operations (Flavourful E-Mail Support, Flavourful Support Web Live Chat).