Flavourful Main Website Down
Incident Report for Flavourful
Resolved
This incident has been resolved.
Posted Apr 26, 2022 - 06:07 UTC
Update
We are continuing to investigate this issue.
Posted Apr 26, 2022 - 06:00 UTC
Investigating
We are currently investigating this issue.
Posted Apr 26, 2022 - 05:56 UTC
This incident affected: Flavourful Main Website & Bog and Support Operations (Flavourful Support Web Live Chat).